rails boolean fields: `is_foo` or just `foo`? [duplicate]

The plain-adjective form is easily the norm in Ruby and Rails — even?, nil?, empty? and blank? for example. The only method of the form is_#{something}? that I can think of is Kernel#is_a? to determine class identity. So to stick with standard naming conventions, I would leave off the is_ on boolean methods like this.


Of the 2 you should choose the one that sounds better to you: User.active? or User.is_active?

I'd personally opt for the former.

The question mark goody comes from Ruby, not Rails.