How to disable creating .Spotlight-V100 and .Trash folders on external drive?

Everytime I put a USB Flash Driver the Mac OS X creates 2 folders .Trash and .Spotlight-V100. Is it possible to disable this operation?


Well, I know that there is utilities to do this, but I can't recall the name right now...

But my Google-Foo, is working today...

$ cd /Volumes/your\ target\ volume
$ sudo touch .metadata_never_index

This hidden file is recognized by both Leopard and Snow Leopard (Possibly Tiger too).

But it will not stop a spotlight index that is currently being created... So add the drive to the privacy panel of Spotlight, add the file, and then remove it from the privacy panel.

Doing so will erase the contents of the spotlight index on the drive in question, prevent it from being re-indexed...


To prevent indexing your external drive, you can add it to Privacy rule in Spotlight (System Preferences).

Prevent Spotlight from searching these locations

To prevent .DS_Store files from being created, run:

defaults write com.apple.desktopservices DSDontWriteNetworkStores true

Source: How to Prevent .DS_Store File Creation


Alternatively to prevent indexing create empty file .metadata_never_index on the drive.

Used by the OS X system as a settings file, the .metadata_never_index file extension is one of the only ways to prevent certain indexing programs like Apple Spotlight from automatically indexing the metadata. Other Apple devices such as iPod/iPad also uses the .metadata_never_index file extension. Another option is to create a drag-and-drop AppleScript to install the .metadata_never_index.

It must be located in a root directory to be ultimately functional.

It can be created from Terminal by touch .metadata_never_index command.

Other options for managing indexes - deleting, pausing and updating - are also available.


To disable indexing on all volumes, run:

sudo mdutil -a -i off

To re-enable:

sudo mdutil -a -i on

Following aliases can be useful to add to your bash rc files.

# Start/stop indexing on all volumes.
alias spotlight_off='sudo mdutil -a -i off'
alias spotlight_on='sudo mdutil -a -i on'

# Load/unload Spotlight Launch Daemons.
alias spotlight_unload='sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist'
alias spotlight_load='sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist'

At least on macOS Mojave (10.14) I found that the mdutil -h command was very much my friend... try:

sudo mdutil -X /path/to/volume

but you may also need to explore options such as -d and -i off because the help states that -X doesn't disable indexing.