How do I burn an ISO on a USB drive on Mac OS X?
what's the best way to get an ISO "burned" to a USB stick on a Mac? Restoring using Disk Utility does not work.
The ISO is ubuntu mini.iso. It is the minimalist install ISO for installing ubuntu. It needs to be bootable on a PC. I am trying to install ubuntu on a PC that has no CD-ROM. The only other computer I have around is a macbook.
Directly from the How to install Ubuntu on MacBook using USB Stick page (my formatting):
- Download the desired file
- Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)
- Convert the .iso file to .img using the convert option of hdiutil (e.g.,
hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso
) - Note: OS X tends to put the .dmg ending on the output file automatically. Remove the .dmg extension as necessary,
mv ~/path/to/target.img{.dmg,}
- Run
diskutil list
to get the current list of devices - Insert your flash media
- Run
diskutil list
again and determine the device node assigned to your flash media (e.g./dev/disk2
) - Run
diskutil unmountDisk /dev/diskN
(replaceN
with the disk number from the last command; in the previous example,N
would be 2) - Execute
sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m
(replace/path/to/downloaded.img
with the path where the image file is located; for example,./ubuntu.img
or./ubuntu.dmg
). - Using
/dev/rdisk
instead of/dev/disk
may be faster.- If you see the error
dd: Invalid number '1m'
, you are using GNUdd
. Use the same command but replacebs=1m
withbs=1M
. - If you see the error
dd: /dev/diskN: Resource busy
, make sure the disk is not in use. Start Disk Utility.app and unmount (don't eject) the drive.
- If you see the error
- Run
diskutil eject /dev/diskN
and remove your flash media when the command completes - Restart your Mac and hold down Alt while the Mac is restarting to choose the USB stick
Note: On newer Macs you might have to install an EFI boot manager to boot from USB.
See also: Download Ubuntu Desktop.
I had a very similar problem that none of these answered.
It's worth checking out UNetbootin. It will create a bootable USB disk on a Mac for a PC.
There is no need to convert the ISO to an IMG. I wasn't willing to convert an image first. This has easier steps, outlined below.
Start by listing the current disks and volumes:
diskutil list
Now unmount the current volume for the disk you are about to overwrite. (X = Drive number, in my case was 1):
diskutil unmountDisk /dev/diskX
Now dd the iso directly to the usb (again replace X with drive number of your USB drive):
sudo dd if=/pathto/mini.iso of=/dev/diskX bs=1m
Done!