How do I restore a Windows 8 iso image to a USB disk in OS X?

I am on OS X and have a Windows 8 Consumer Preview x64 image. My computer doesn’t have a CD drive (MacBook Air). I have a 4 GB USB drive. I want to restore that image to the USB drive. There are many tools to do that on Windows, but I can’t finger out how to do it in OS X. Please note that I can’t run a VM, as my Air is a limited use machine.

What I’ve tried:

  • Simply restore to USB.
  • Convert the image to img and use dd.

These don’t work.

How do I go about doing this?

EDIT: Ok, everyone, really sorry for the confusion. I am new here.

To clear my motive, I am trying to create a bootable USB Windows 8 installer to install Windows 8 Consumer Preview (which apparently requires a product key, something I don’t have) so that I can use it later to install Windows 8 CP on my Mac Book Air. Using Bootcamp, according to what I have read and tried, is not an option. As suggested, I tried using Boot Camp Utility to prepare the USB drive, but unfortunately, that simply isn’t working and I can’t troubleshoot it.


Solution 1:

Prepare the USB key

We’re going to wipe the partition structure on the USB key. WARNING! THIS WILL DESTROY ALL DATA ON THE KEY!

Open up Disk Utility (it’s in /Applications/Utilities/).

Now do the following:

  1. Select the USB key (select the root device, not its partitions)
  2. Select the partition section at the top
  3. Change the Scheme to 1 Partition
  4. Change the Format to Free Space
  5. Click Apply

You will get a confirmation dialog appear ensuring you really want to delete all data on the key, choose Partition.

Once it’s completed you can quit out of Disk Utility.

The purpose of doing this is mainly to ensure that the USB key is in a consistent known state and also to ensure that any volumes are not mounted by OS X. It is not required and you can skip it if you’d rather just unmount the volumes yourself.

Preparing the ISO image

Now that our USB key is ready, we need to get our .iso image into a format that we can copy to it. Open up a Terminal (it too is in /Application/Utilities, and I’ll assume you know how to use the terminal)

Now, convert the image from a ISO to a Read/Write Universal Disk Image Format (or UDRW). Here I’m using the xbmc live repack ISO, but you can use anything else that’s an ISO file.

(#503:14u:0s) evan@8thwonder[/Users/evan/Downloads]: hdiutil convert -format UDRW -o xbmc-9.11-live-repack.img xbmc-9.11-live-repack.iso Reading XBMC_Live (Apple_ISO : 0)… ......................................................................................................................................................................................................... Elapsed Time: 24.475s Speed: 20.0Mbytes/sec Savings: 0.0% created: /Users/evan/Downloads/xbmc-9.11-live-repack.img.dmg

Once completed this will create the .img file. The hdiutil function likes to append a .dmg suffix to the file so it will probably end up .img.dmg after conversion.

Copy the image to the USB key

We’re finally here. The easy part, actually copying the image to the USB key.

First run diskutil list to get a listing of the disks in your machine so you can identify the USB key. It will look like this:

(#504:14u:0s) evan@8thwonder[/Users/evan/Downloads]: diskutil list /dev/disk0 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *250.1 GB disk0 1: EFI 209.7 MB disk0s1 2: Apple_HFS Macintosh HD 249.7 GB disk0s2 /dev/disk1 #: TYPE NAME SIZE IDENTIFIER 0: *1.0 GB disk1

Here mine’s /dev/disk1.

We want to use the RAW disk device so that our copy will happen much faster because the RAW disk device provides unbuffered access to the device (See this Apple mailing list post for more info). This is accomplished by simply prepending ‘r’ to the device so that /dev/disk1 is going to become /dev/rdisk1

Next we use the dd command to copy the image over.

(#506:14u:0s) evan@8thwonder[/Users/evan/Downloads]: dd if=./xbmc-9.11-live-repack.img.dmg of=/dev/rdisk1 bs=1m

On the command line we specify the Input File using if= and the Output File using of= and dd will copy the data from input to output, block by block.

Once it’s completed you can exit Terminal and remove the USB key from your OS X machine, it should now be able to bootup your ISO on another machine.

NOTE: I wish I could take a credit for this, but I can't, here is the source.

Solution 2:

The Bootcamp utility will do this for you.

Edit: Are you trying to run Windows 8 from the USB drive? I think we were all reading your question as if you wanted to install from the USB drive. However, based on your claim that you don't want to install Windows, I'm wondering if you are looking for Windows To Go, which would allow you to boot and run Windows 8 from the USB drive without having it installed on the machine.

If that's what you're trying to do, then this article explains the process. You'll need a 32 GB or larger USB 3.0 drive and a machine that already has Windows 8 installed on it, so this might not work for you since you want something that runs on your Macbook Air and OS X.

Also, I believe Virtual Box will run on a machine that doesn't have hardware support for virtualization. Have you looked into that.

One other thing to note, there is a 90-day trial available for Windows 8 RTM, which might be a better option than the Consumer Preview if you just want to try it out. http://msdn.microsoft.com/en-US/evalcenter/jj554510.aspx?wt.mc_id=MEC_132_1_4