Stop Docker from automatically starting on startup

I installed Docker on OS X, and now it automatically loads every time I log in. Is there a way to stop this?


Solution 1:

Click the Docker icon in the right hand side of the menu bar, and click "Preferences". In the dialog that appears, untick "Automatically start Docker when you log in".

Screenshot

Solution 2:

The locations are

cd ~/Library/LaunchAgents
cd ~/Library/LaunchDaemons

cd ~/Library/LaunchAgents
cd ~/Library/LaunchDaemons

But I recommend you just remove using launchctl remove

launchctl list | grep docker

launchctl remove com.docker.helper
launchctl remove com.docker.docker.11008