How can I install a Windows 7 into BootCamp via USB
I have a MacBook and I'd like to install Windows 7 via USB. I've created the partition using Boot Camp and I've got an .ISO of my Windows 7 install disk. Is it possible to install this via USB, instead of burning a DVD?
Solution 1:
Through Disk Utility you can restore the Windows 7 ISO onto the flash drive.
When you hold option at startup to access the boot options the disc will appear.
Note: When you do the restore through Disk Utlity make sure your flash drive is partitioned correctly.
It needs to be partitioned as Mac OS X journaled (HFS+) - this will enable the GUID partition map (so the boot menu can read the ISO). Next, click source and within the finder locate the ISO and you're set.
Solution 2:
With Lion, Apple has added an option to BootCamp that will create a bootable USB Windows 7 install disk, this option is only enabled in Mac models which don't have an optical drive. To enable this option just follow this guide.
Solution 3:
This worked for me:
Burn ISO to bootable USB flash drive in Mac OSX terminal (via command line Diskutil)
- Convert the .iso file to .img using the convert option of hdiutil (e.g.,
hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso
)- Note: OS X tends to put the .dmg ending on the output file automatically.
- Run
diskutil list
to get the current list of devices- Insert your flash media
- Run
diskutil list
again and determine the device node assigned to your flash media (e.g. /dev/disk2)- Run
diskutil unmountDisk /dev/diskN
(replace N with the disk number from the last command; in the previous example, N would be 2)- Execute
sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m
(replace N with your disk number)- Run
diskutil eject /dev/diskN
and remove your flash media when the command completes
Solution 4:
Make sure to run the Bootcamp assistant before you try to boot off the flash drive. Follow the instructions in How to install Windows 7 from USB, then see if the computer will recognize the flash drive when you boot up. To choose different boot media when a Mac starts, press Option, then select the flash drive if it appears.
If that doesn't work, post in the comments; there may be more steps required to get it to boot off of the external drive.