Word to describe both adding and removing but not updating
I am looking for a word that can describe the act of adding/removing objects but at the same time avoid a word that has to do with updating.
So, given
- adding an object,
- removing an object,
- updating an object,
I want a word for ((1 and 2) and not 3). So I guess words like alter won't do.
Edit: I am actually making an application, and I have three methods; adding, removing and updating. But there is some logic in both the adding and removing that is common. I then decided to make a fourth (helper) method. That's why I need this word so badly.
Solution 1:
A class containing a collection of immutable objects might be a stack, where you push items in and pop them out. But if PushPop()
doesn't do it for you, how about something like shift, with the implication that you can shift items onto or off of the stack.
Solution 2:
If this is about method naming, then you really don't need a bona fide English word. You can construct your own hybrid. The obvious one that comes off the top of my head is
addOrRemoveObject()
but you should feel free to use whatever fits with your naming convention.