Disable all the idiot-checking in Mac OS X

Solution 1:

If you want to stick with Finder (rather than using some third-party file manager such as Path Finder), then I don't know if there's an easy way to get what you want in one click. But, to run Finder as root:

sudo /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder

In Snow Leopard this does not (always?) open an initial Finder window. If that happens, then do not click the Finder icon in the Dock (which might take you to the non-root Finder), but use Command-Tab to go to Finder and hit Command-N. Note the "root" name in the sidebar next to the home folder.

Alternatively, Apple explains Enabling and using the "root" user in Mac OS X.

To show hidden files:

defaults write com.apple.finder AppleShowAllFiles 1

Solution 2:

Well gee, I suppose you could always log in as root: the following link will bring you to the Apple Knowledge Base page on how to enable the root account on Mac OS X, which is disabled by default. http://support.apple.com/kb/ht1528

Other things: any directory you find while browsing through the terminal can be viewed in Finder by using the open command. $ open . is a simple terminal trick to open the current working directory in the Finder.

From within the Finder, you can also go directly to any directory on the system from the "Go to Folder..." item in the "Go" menu (command+shift+g); this will display a dialog that will do tab autocompletion just like the command line.

All of Mac OS X's system files are not hidden. They're stored in /System, specifically /System/Library/CoreServices.

For "Tweaking important OS components," maybe you should install the developer tools? I'd be surprised if you haven't done this already, but that will get you things like Property List Editor and the SetFile command.

Speaking of SetFile, the Darwin system files are hidden from the user. If you do $ ls -a / from the command line, you'll see all of the /bin, /var, /etc. that form the BSD subsystem. You can easily show these in the Finder by unsetting the invisible flag with $ SetFile -a v /theDirectoryInQuestion, or make use of the AppleShowAllFiles property that Arjan mentioned just now. (Note: SetFile used to be available only as part of the Developer Tools package, but appears to be part of the regular system now.)

I'm really not sure what you're looking for specifically. The concept is if you want to access the BSD subsystem files, you may as well be using the BSD subsystem through Terminal. Nearly all of OS Xs files are available to the user in the Finder. The tools I use most commonly for tweaking OS X are plutil, vi, SetFile, launchctl, all from the command line.