How much storage should be taken up by 'System' in MacOS Sierra

If you are on High Sierra then… it's TimeMachine fault.

That's the solution that worked for me.

Type this command in you terminal:

sudo tmutil listlocalsnapshots /

to check the snapshots of TimeMachine. You get some strings like these:

com.apple.TimeMachine.2017-10-02-132639
com.apple.TimeMachine.2017-10-02-175507
com.apple.TimeMachine.2017-10-02-200417
com.apple.TimeMachine.2017-10-02-235853
com.apple.TimeMachine.2017-10-03-112713
com.apple.TimeMachine.2017-10-03-112934
com.apple.TimeMachine.2017-10-03-113254

You need this command to delete TimeMachine mess:

tmutil deletelocalsnapshots 2017-09-27-112934

Type this command for each of those snapshots (changing the date) and you'll get a great amount of free space!


I believe that when I got my MBP, the size was around 16 GB.

One night the size of the 'System' section of my storage increased 40 GB in an hour (though, I am running the High Sierra Beta). I restarted a few times and nothing seemed to happen. I read an answer somewhere to an issue related to this that I could delete the com.apple.coresymbolicationd folder in /System/Library/Caches/. The system couldn't read the size of the directory so I figured it was a problem folder, so I deleted it, emptied the garbage, and restarted. Now my System section is 50 GB (used to be 120 GB).

Disk Inventory X gave me different sizes than the System Information window and it didn't find any problematically large files. Daisy Disk, however, did find a glob of ~75 GB that it couldn't scan because of permissions, even when scanning as admin. The com.apple.coresymbolicationd directory has restrictive permissions, so I assume that was the culprit.

Deleting that directory isn't harmful to the system as far as I know, and it regenerates when the OS needs it again.

You can also look at the built in Disk Utility. That gave me conflicting reports each restart but did inform me on one restart that ~100 GB of data was purgeable.


I'm not entirely sure what Apple considers to be "System". Mine is using about 40GB. Apple's calculator seems a bit unclear and I'm unable to find an explanation of what is included in that breakdown. Here is my actual system usage:

enter image description here

I would suggest using a better application that does not use a generic breakdown, but will show you which large files are taking up so much space, perhaps something like Disk Inventory X.


I had the same problem. My System folder was 50 GB, my Applications folder was 20 GB, and my Downloads, Music, etc accounted for about 20 GB. And my "About this Mac" was showing "System" space used as 160 GB, thus showing that there was no disk space any more on my 256 GB mac.

So I spent some time found where this "160 GB" was being used. In the Users/<user>/Library folder, one of my application had created a directory and was storing some files over there which accounted for majority of the 160 GB. I removed that application and deleted this folder which resolved my problem.

Note that deleting anything in a system folder can be harmful, so only do it if you know w


Mainly, abnormal "system" size in macos is all about this path /private/var/folders/w3. Its some kind of system temporary folder, in which you can find xcode publishing archives of different versions(if you use xcode) and lots of data, that could be restored when needed.

Also you can clear the data, which is marked in storage preferences as Purgeable Data this way:

  • list your volumes by df -h
  • run secureErase for system volume by sudo diskutil secureErase freespace 0 /dev/disk1s1

Also delete unused simulator images in xcode/window/devices and simulators/simulators, you can easily install them again when needed from Xcode/Preferences/Components, and clear this folder /Users/your_user/Library/Developer/Xcode/iOS DeviceSupport This folder expands each time when new device connected, and could be easily erased.