cisco router not nat to outside network

im trying to get PC access to outside network without any natting to outside network in router in stick config, problem is im unable to ping from outside network 10.130.1.0 to inside netwrok 10.1.10.101, plz assist

enter image description here

interface GigabitEthernet0/0/0
 ip address 10.130.1.254 255.255.255.0
 ip nat outside
 negotiation auto
!
interface GigabitEthernet0/0/1.20
 encapsulation dot1Q 20
 ip address 10.1.11.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface GigabitEthernet0/0/1.110
 encapsulation dot1Q 110
 ip address 10.1.10.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip default-gateway 10.130.1.1
ip nat translation tcp-timeout 600
ip nat translation udp-timeout 600
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.130.1.1

Solution 1:

You did not enable NAT. You need something like:

ip nat inside source list 1 interface GigabitEthernet0/0/0 overload
!
access-list 1 permit 10.1.10.0 0.0.0.255
access-list 1 permit 10.1.11.0 0.0.0.255
!

The above will determine and match the interesting traffic that you want to NAT.


Also, you never use the ip default-gateway command on a router with routing enabled. Cisco has a document that explains: Configuring a Gateway of Last Resort Using IP Commands:

The ip default-gateway command differs from the other two commands. It should only be used when ip routing is disabled on the Cisco router.

You can, and should, eliminate the ip default-gateway command if ip routing is enabled. This is a mistake that rookies often make.


im unable to ping from outside network 10.130.1.0 to inside netwrok 10.1.10.101

As far as network 10.130.1.0/24 or any network outside that, the inside networks do not exist. The outside networks only see the router 10.130.1.254 address because all the inside addresses are translated to that address. The outside devices cannot ping the inside devices. You can forward specific TCP or UDP ports to specific inside addresses.