Patching AIX systems - patches are where? how to apply?

I'm not an AIX guru.....I've been assigned to patch my systems up to the latest patch level.

First, where do I get the patches for AIX 5.1 and 5.3?

Second, how are they generally installed (i.e. commands and procedures).

Thanks for your help.


Solution 1:

Software maintenance in AIX is complicated and alien to the uninitiated. These days, major major AIX OS updates are referred to as a "maintenance level" (ML) and revisions to those code drops are referred to as "service packs" (SP). You'll want to determine what level you systems are currently at and the level you wish to upgrade to prior to starting the process. Use the "oslevel" command to display the software level of a system:

$ oslevel
6.1.3.0

Here, oslevel is run without args and displays the base software level, v6.1 ML 3 in the example

To display the SP level use,

$ oslevel -s
6100-03-02-0939

Here, we are at ML 3, SP 2 of AIX 6.1

NOTE: I would recommend reading the latest version of the Services and Support Best Practices doc before going very far as the info given here barely scratches the surface of the subject.


As stated in a previous answer, SUMA is the way to go for quickly gathering OS updates, particularly when one is unfamiliar with navigating the IBM support site and/or AIX maintenance practices in general. With that said, SUMA offers a slew of options and features that can definitely confuse a newbie so here is a short usage scenario:

  1. determine the software level that you wish to apply to your systems.
  2. use SUMA to download the packages
  3. perform a test install of the packages
  4. download any missing dependencies using Fix Central (linked in a previous comment) or SUMA itself (SUMA's fileset search can be hit or miss, however)
  5. Rinse and repeat until the test comes out clean, then install for real

Here is a sample SUMA command invocation that would download the updates need to bring a v5.3 system to ML 9:

$ suma -x -a RqType=ML -a RqName=5300-09 -a Action=Download

  1. -x: perform the SUMA action now rather than scheduling a job using SUMA's built-in schedule
  2. -a RqType=ML: set the Request Type to ML
  3. -a RqLevel=5300-09: select ML 09 of the AIX 5.3 release
  4. -a Action=Download: set the command action to download. This is the default but it is included here for clarity.

By default, SUMA will download packages to the directory /usr/sys/inst.images/installp/ppc. Unless it is interrupted, SUMA will perform an inutoc command in the download directory so there is no need to do so following its run.


Once the software is downloaded, it can be installed using smitty:

$ smitty update_all

or using the "update_all" command:

$ update_all -d /usr/sys/inst.images/installp/ppc -p

The "-p" in the "update_all" command signifies "pretend" mode. Remove it after the pretend runs cleanly.


Hopefully this helps you get started but these snippets are no substitute for plowing through the AIX docs. Good luck.