How to make a bootable USB key from an .iso image on Mac OS X? [duplicate]

Possible Duplicate:
How do I make a bootable USB flash drive for a MacBook Air?

How to make a bootable USB key from any .iso image on Mac OS X?


Solution 1:

The easiest way is to right click on the .iso file and select 'Burn Disk Image XXX to Disc...". This will run Burn app with appropriate settings. When ready, hit the Burn button.


Here is longer version for advanced users.

Based on this article, you should:

  1. Open up Disk Utility.
  2. Select the USB key (select the root device, not its partitions).
  3. Select the partition section as shown below:

  4. Change the Scheme to 1 Partition

  5. Change the Format to Free Space
  6. Click Apply

    WARNING! THIS WILL DESTROY ALL DATA ON THE KEY!

  7. Once it’s completed you can quit out of Disk Utility.

The purpose of doing this is mainly to ensure that the USB key is in a consistent known state and also to ensure that any volumes are not mounted by OS X. It is not required and you can skip it if you’d rather just unmount the volumes yourself.

Next you need to prepare ISO image by following the below command:

[#542]: hdiutil convert -format UDRW -o debian-6.0.7-amd64-netinst.img debian-6.0.7-amd64-netinst.iso 
Reading Master Boot Record (MBR : 0)…
Reading Debian 6.0.7 amd64 1             (Apple_ISO : 1)…
Reading  (Windows_NTFS_Hidden : 2)…
.....................................................................................................................................................................................................................................................
Elapsed Time:  2.054s
Speed: 81.8Mbytes/sec
Savings: 0.0%
created: /Users/evan/Downloads/debian-6.0.7-amd64-netinst.img.dmg

Finally you need to copy the image to your USB drive. First identify your disk device path by:

[#543]: diskutil list
/dev/disk0
   #: TYPE NAME SIZE IDENTIFIER
   0: GUID_partition_scheme *250.1 GB disk0
   1: EFI 209.7 MB disk0s1
   2: Apple_HFS Macintosh HD 249.7 GB disk0s2

/dev/disk1
   #: TYPE NAME SIZE IDENTIFIER
   0: *1.0 GB disk1

Update: We want to use the RAW disk device so that our copy will happen much faster because the RAW disk device provides unbuffered access to the device (See this Apple mailing list post for more info). This is accomplished by simply prepending ‘r’ to the device so that /dev/disk1 is going to become /dev/rdisk1

Update 2: Specifying a blocksize of 1m will also significantly speed things up.

Next use dd command to copy the image over:

[#544]: dd if=./xbmc-9.11-live-repack.img.dmg of=/dev/rdisk1 bs=1m

On the command line we specify the Input File using if= and the Output File using of= and dd will copy the data from input to output, block by block.

Once it’s completed you can exit Terminal and remove the USB key from your OS X machine, it should now be able to bootup your ISO on another machine.


To boot the system from such a drive, press ⌥ immediately after rebooting.