How do you uninstall Puppet from Mac OS X ?

Solution 1:

Puppet does not have an uninstaller, you must manually remove the following files. (Tested on 3.2.3)

Uninstalling

Remove the following binaries

/usr/bin/puppet
/usr/sbin/puppet

Remove the following directories

/private/etc/puppet
/usr/share/doc/puppet

To get rid of the puppet user that appears on the login screen

sudo dscl . delete /Users/puppet

You will need to reboot for the user to disappear


resources
spuders blog - how to remove puppet from Mac
delete puppet installed via ruby
remove hidden user from mac

Solution 2:

The above answer is incomplete, not all the files are removed with the above commands.

I was able to completely uninstall Puppet (on Mountain Lion) by running the following commands:

for f in $(pkgutil --only-files --files com.puppetlabs.puppet); do sudo rm /$f; done
for d in $(pkgutil --only-dirs --files com.puppetlabs.puppet | tail -r); do sudo rmdir /$d; done
sudo pkgutil --forget com.puppetlabs.puppet