Macbook Pro hanging on Boot Screen After Driver Installation
Solution 1:
You're looking at the wrong /System/Library/Extensions
. You've booted into macOS Recovery, which lives on its own volume separate from your normal boot volume. This means that all filesystem paths are relative to the root of the Recovery volume, not your boot volume.
Try first cd
ing into /Volumes/YourBootVolumeName
and continuing from there. When you find the appropriate KEXT(s), you can delete them or move them outside of the Extensions/
directory.
You will then also need to run the following command in order to update the kernel extension cache, otherwise you'll still be trying to boot as if you never deleted the Fresco Logic KEXTs: kextcache -update-volume /Volumes/YourBootVolumeName
Solution 2:
The package comes with an uninstaller script, from which I was able to scavenge this list of file locations & deletion commands…
sudo rm -f /usr/local/libexec/screen_capture
sudo rm -f /Library/LaunchDaemons/com.frescologic.screen_capture.plist
sudo rm -f /Library/LaunchAgents/com.frescologic.screen_capture.plist
sudo rm -r /Library/LaunchAgents/com.frescologic.screen_capture-prelogin.plist
sudo rm -rf /Library/Extensions/FL2000.kext
sudo rm -rf /Library/Extensions/IOProxyVideoCard.kext
sudo rm -rf /Library/Extensions/IOProxyFramebuffer.kext
echo Please restart your computer for changes to take effect.
You should be able to run these from terminal