How to kextunload in OS X Lion
kextunload
can use the full Kernel Extension path, just like kextload
.
sudo kextunload /System/Library/Extensions/msdosfs.kext
If you want to use the bundle identifier – the one listed by kextstat
–, use the -b
switch:
sudo kextunload -b com.apple.filesystems.msdosfs
kextload man page can give you details. Here is the command I've been using:
sudo kextload /path/to/file.kext
OR kextutil man page, this tool is useful for get some debug messages if there are errors in the loading process.
sudo kextutil /path/to/file.kext
And of course, the kextunload man page in the other answer. Here is the command I mainly use since I don't like to write out the entire bundle id:
sudo kextunload /path/to/file.kext
You can also use kextstat
to verify if your kext file has been loaded:
kextstat | grep -v apple
This will list all third party kexts as long as 'apple' is not in the bundle id.
i had the same problem (Can't create –b. ; Can't create com.apple.driver.AppleUSBFTDI.) trying "sudo kextunload –b com.apple.driver.AppleUSBFTDI" on os x 10.9.5
but after i used the full path (sudo kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBFTDI.kext/), it worked...
that only happens on some kexts, for eg on other kext (/System/Library/Extensions/FTDIUSBSerialDriver.kext) , it works perfect with "sudo kextunload -b com.FTDI.driver.FTDIUSBSerialDriver"