macOS High Sierra: Create Windows bootable Usb
Solution 1:
This can be done by console for Windows 10 iso images (Not sure about 8/7, but leave any comment if it worked for you).
Start connecting your usb drive and type diskutil list
to display all connected drives.
You'll see something like:
/dev/disk0 (internal):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme 500.3 GB disk0
1: EFI EFI 314.6 MB disk0s1
2: Apple_APFS Container disk1 500.0 GB disk0s2
/dev/disk1 (synthesized):
#: TYPE NAME SIZE IDENTIFIER
0: APFS Container Scheme - +500.0 GB disk1
Physical Store disk0s2
1: APFS Volume Macintosh HD 185.7 GB disk1s1
2: APFS Volume Preboot 47.1 MB disk1s2
3: APFS Volume Recovery 512.8 MB disk1s3
4: APFS Volume VM 4.3 GB disk1s4
/dev/disk2 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *15.6 GB disk2
1: DOS_FAT_32 LALA 15.6 GB disk2s1
For my case, the usb drive was /dev/disk2
. Knowing this, format your usb drive with:
diskutil eraseDisk MS-DOS "WINDOWS10" MBR disk2
where disk2
is the usb drive id known in the prior command and "WINDOWS10"
is the volume label (to be used later).
Please double check this step, or you could delete all data in another drive.
Then mount your image with:
hdiutil mount your_windows_10_image.iso
the command will return the location of the mounted iso
/dev/disk3 /Volumes/CPRA_X64FREV_ES-MX_DV5
so finally copy all the files from the mounted iso to your usb drive:
cp -rpv /Volumes/CPRA_X64FREV_ES-MX_DV5/* /Volumes/WINDOWS10
Solution 2:
For the future search, this solution works for me:
https://joshb.github.io/2017/11/23/making-a-bootable-windows-10-usb-drive-on-macos-high-sierra/