macOS Sierra : dd to USB is very slow and can't seem to use /dev/rdisk

I installed the same image last night on a RPi3.

You need to unmount the disk first. Then you can write to the disk using sudo.

diskutil unmountDisk /dev/rdisk2
sudo dd bs=1m if=~/Downloads/your_image.img of=/dev/rdisk2
diskutil unmountDisk /dev/disk2

I'm on macOS Sierra, too.


It works for me! You may be interested the the script I use, which can copy images and compressed backups.

It includes checks to prevent you inadvertently overwriting something else and automatically unmounts the SD Card.

You need to customise the script with disk and image.

#!/bin/bash
# script to restore backup to Pi SD card
# 2016-10-24

DSK='disk3'

# Image name (no ext)
IMG='ubuntu-standard-16.04-server-armhf-raspberry-pi'

# Check for sensible disk
export PTYPE=$(diskutil list  /dev/$DSK | awk '/GUID_partition_scheme/ {print $2}; /Apple/ {print $2}; /Windows_NTFS/ {print $2}' )
if [ "$PTYPE" ]; then
    echo "Disk not a SD Card - Contains "$PTYPE
    exit
elif [ ! /dev/$DSK ]; then
    echo "/dev/$DSK not found"
    exit
fi

echo Ensure SD partitions are unmounted!
diskutil unmountDisk /dev/$DSK

# Check if image exists - else try to uncompress
if [ -s $IMG.img ]; then
echo $IMG.img exists
elif [ -s $IMG.img.gz ]; then
echo Uncompressing $IMG.img.gz
echo Ctl+T to show progress!
time  gunzip -k $IMG.img.gz
fi

echo please wait - This takes some time
echo Ctl+T to show progress!
time sudo dd if=$IMG.img of=/dev/r$DSK bs=1m

exit