How do I clear the purgeable area on my disk?

Another option to flush purgeable disk space is to manually create empty disk images, either from Disk Utility (with Cmd+N) or from the terminal, like this:

$ hdiutil create -size 25g empty.dmg
created: /Users/enekoalonso/empty.dmg

This command takes a few seconds, using the default image parameters.

As a note, we cannot create an image larger than the free space available, but using a value close to that will trigger macOS to release a good amount of purgeable space.

This process can easily be repeated as needed, until almost all purgeable space has been released.


You can create a huge file that will force macOS to clean purgeable files to free you space. Do do so, type this command in a terminal:

dd if=/dev/zero of=~/hugefile bs=15m

It will create a file called hugefile in your home folder, which you can check the size with Get Info and stop when it's big enough for you, using ControlC. Or you can simply let it run until you are out of space in the disk and things start to stop working.

This command takes a long time to allocate the memory, you can also stop it when it's 5~10GB and duplicate the file CommandD to create copies and speed up the process.

Then, you just need to delete the files, obviously.

In your case, you already have the file you want to copy, so you could split it into 50 GB chunks and copy one chunk over. Then let the system purge files and repeat. Once you have all the data over, you can combine them - adding the second file to the first, deleting the second file, etc...

  • How to merge files after using split command from terminal?

The main problem is that “purgeable” space is not one monolithic item - it is potentially local time machine or filesystem snapshots, cached data, derived data, iCloud photos at full resolution that will be downsampled as you start to get closer to no free space available.

The system will self correct if you can bring the data over in two pieces in your case, or in n-pieces in the general case.


If time machine is the taking the space, than using tmutil can help. List of snapshots can be checked using:

tmutil listlocalsnapshots /

And cleanup upto 100GiB using:

tmutil thinlocalsnapshots / $((100 * 1024 * 1204 * 1024)) 4

Last two arguments are:

  • amount of space to try to reclaim (using $(( )) to calculate 100 GiB)
  • urgency, 1 is default, 4 is highest (didn't find better description)

There is a mention of tmutil in a comment, but not of thinlocalsnapshots.


I was able to cause the purgeable area to get cleared by copying over temporary smaller files which eventually caused the purgeable space to be cleared. Once the large purgeable area was cleared then I could delete the temporary smaller files and copy the large one that I intended.

Note, that deleting the smaller temporary files caused my purgeable area to grow again, fortunately it grew small enough that I could copy the large file over. Hopefully Apple refines this over time.


There seems to currently be no way of getting a list of what the OS considers purgeable files in order to delete them, but there are some candidates to consider, such as cached files.

This particular file can grow quite large, and once removed reduces the purgeable data size;

/System/Library/Caches/com.apple.coresymbolicationd/data

To get an idea of the size of the file, you can run ls as the sudo user;

sudo ls -la /System/Library/Caches/com.apple.coresymbolicationd/data

A search for the file provides a few links to queries on its size, such as this Q&A here.

Details on the file itself are scarce, but it seems related to symbol lookup for crashed and problematic processes; as is evidence in this linked Q&A, with more information this post. Follow on the Q&A linked above, it does seem safe enough to delete, this file.

Removal of the file would need to be done with sudo, details are provided in the Q&A post. The gist of it is to move (as sudo) the file to somewhere in your home directory (e.g. ~/Documents/SymbolDataDelete), reboot the machine and then delete the file.

Note: the symbol file will be created again, this appears to be normal, but you should be able to better manage the size it consumes if it becomes too large.

Warning: using sudo can be dangerous... use with care.

On the expected results; I don't anticipate that this single file will be the sole contributor to the purgeable data (assuming the cloud drive is off etc.), but it did clean up about 95% of the purgeable data I had.

General observations

It may seem obvious, but a reboot cleans out a lot of the temporary and cached content. Give it a few minutes after the restart. Personal observations have been that after a couple of weeks, a reboot cleans up in the order of a gig of purgeable space...