Does OS X have an equivalent to /dev/shm?

You can create and mount a ram based disk as follows:

  1. Create a disk

    hdiutil attach -nomount ram://$((2 * 1024 * SIZE_IN_MB))
    

    hdiutil will return the name of the ramdisk.

  2. Format and mount the disk

    diskutil eraseVolume HFS+ RAMDisk NAME_OF_DISK
    
  3. Access the disk under /Volumes/<diskname>

    cd /Volumes/RAMDisk && touch testfile.txt && ls
    

Creating a 100MB ramdisk:

$ hdiutil attach -nomount ram://$((2 * 1024 * 100))
/dev/disk3

$ diskutil eraseVolume HFS+ RAMDisk /dev/disk3
Started erase on disk3
Unmounting disk
Erasing
Initialized /dev/rdisk3 as a 100 MB case-insensitive HFS Plus volume
Mounting disk
Finished erase on disk3 RAMDisk

Original source: http://www.frederico-araujo.com/2008/12/18/blazing-fast-firefox-using-osx-ramdisk/