Naming Conventions: What to name a method that returns a boolean? [closed]

Solution 1:

IsRetrievable()

I think that a method that returns a boolean value should be named as a yes-no question.

Solution 2:

Allways name boolean methods with names similar to questions that can be answered Yes or No.

In your case, CanRetrieve would be a good name (just to use your own suggestion).