List all devices connected, lsblk for Mac OS X
diskutil list
will list all disks with their identifiers, even if unmounted.
/dev/disk0
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *251.0 GB disk0
1: EFI EFI 209.7 MB disk0s1
2: Apple_HFS Mac SSD 150.0 GB disk0s2
3: Apple_Boot Recovery HD 650.0 MB disk0s3
4: Microsoft Basic Data Windows 8 100.1 GB disk0s4
/dev/disk1
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *500.1 GB disk1
1: Apple_HFS George Garside 300.2 GB disk1s1
2: Windows_NTFS GRGARSIDE 199.9 GB disk1s2
For mounted disks only…
To find the raw device name (i.e. /dev/disk0s1
) you can run df
.
You can limit the results to locally-mounted filesystems, use df -Hl
.
This results in a list of partitions and their raw device names, as shown below:
Filesystem Size Used Avail Capacity iused ifree %iused Mounted on
/dev/disk0s2 150G 130G 20G 87% 31761475 4859615 87% /
/dev/disk0s4 100G 83G 17G 83% 184667 17015601 1% /Volumes/Windows 8
/dev/disk1s1 300G 282G 19G 94% 68771109 4529660 94% /Volumes/George Garside
/dev/disk1s2 200G 172G 27G 87% 144125 26731127 1% /Volumes/GRGARSIDE
Mac OS X offers the system_profiler
utility that can be run from Terminal. You can pipe it through grep to find specific strings that you want.
Adding this answer to complement @aglasser's answer.
If you want to list all the USB Devices connected to your mac, run this in the Terminal app
system_profiler SPUSBDataType
List all PCI devices
system_profiler SPPCIDataType
From at least High Sierra 10.13.6 you can use the system profiler (About This Mac > System Report > SATA/SATA Express) to give you a list of all mounted SATA devices and get the UUID of each mounted Disk by name. If you have unmounted drives use Disk Utility to mount them.